PHP四个本子的剖析解释

PHP版本主要分三支:PHP4/PHP5/PHP6
其中,PHP4由于太古老、对OO支持不力已基本被淘汰,就不在详述。
而PHP6由于基本没有生产线上的应用,还基本只是一款概念产品,所以也不详述。

Configure Command看到VC98字样的是VC6,Compiler标明 MSVC9 (Visual C++
2008) 的是VC9

IIS

If you are using PHP as FastCGI with IIS you should use the Non-Thread
Safe (NTS) versions of PHP.

VC6与VC9
对于VC6还是VC9版本的选择,PHP官方网站有详细的描述
原文如下
Which version do I choose?
If you are using PHP with Apache 1 or Apache2 from apache.org you need
to use the VC6 versions of PHP
If you are using PHP with IIS you should use the VC9 versions of PHP
VC6 Versions are compiled with the legacy Visual Studio 6 compiler
VC9 Versions are compiled with the Visual Studio 2008 compiler and have
improvements in performance and stability. The VC9 versions require you
to have the Microsoft 2008 C++ Runtime (x86) or the Microsoft 2008 C++
Runtime (x64) installed
Do NOT use VC9 version with apache.org binaries

NTS即None-Thread Safe,一般以fast
cgi方式运行的时候选择这个版本,具有更好的性能。

Which version do I choose?

 

如何查看当前运行的PHP的版本?一个很简单的办法就是phpinfo();
Thread Safety disabled是NTS,enabled是TS
Configure Command看到VC98字样的是VC6,Compiler标明 MSVC9 (Visual C++
2008) 的是VC9

如何查看当前运行的PHP的版本?一个很简单的办法就是phpinfo();
Thread Safety disabled是NTS,enabled是TS

我们先来看一段PHP官网的原话:

除了版本号的不同,同一版本号的PHP版本也有区别,并且在选择PHP扩展的时候需要注意。

  • 在WIN7下:IIS7+NTS+FastCGI+vc9 或者apache+fastcgi+nts+vc6较好。

  • 在WINXP下:Apache+TS+Apache module +vc6最合适的搭档。

Apache

Please use the Apache builds provided by Apache
Lounge. They provide VC9, VC11 and VC14
builds of Apache for x86 and x64. We use their binaries to build the
Apache SAPIs.

If you are using PHP as module with Apache builds
from apache.org (not recommended) you need to use the older VC6
versions of PHP compiled with the legacy Visual Studio 6 compiler.
Do NOT use VC9+ versions of PHP with the apache.org binaries.

With Apache you have to use the Thread Safe (TS) versions of PHP.

上面一段话翻译过来就是:

我选择哪个版本?

IIS
如果你使用的是PHP的FastCGI IIS,你应该使用非线程安全(NTS)版本的PHP。

Apache
请使用Apache Lounge提供的Apache构建。
他们提供了针对x86和x64的Apache的VC9,VC11和VC14版本。
我们使用他们的二进制文件构建Apache SAPI。

如果你使用PHP作为apache.org(不推荐)的Apache模块,你需要使用旧的Visual
Studio 6编译的VC6版本的PHP。 不要使用apache.org二进制文件的VC9
+版本的PHP。

使用Apache,您必须使用Thread Safe(TS)版本的PHP。

 

我们来解释下上面的内容:

从2000年10月20日发布的第一个Windows版的PHP3.0.17开始的都是线程安全的版本,这是由于与Linux/Unix系统是采用多进程的工作方式不同的是Windows系统是采用多线程的工作方式。如果在IIS下以CGI方式运行PHP会非常慢,这是由于CGI模式是建立在多进程的基础之上的,而非多线程。一般我们会把PHP配置成以ISAPI的方式来运行,ISAPI是多线程的方式,这样就快多了。但存在一个问题,很多常用的PHP扩展是以Linux/Unix的多进程思想来开发的,这些扩展在ISAPI的方式运行时就会出错搞垮IIS。因此在IIS下CGI模式才是PHP运行的最安全方式,但CGI模式对于每个HTTP请求都需要重新加载和卸载整个PHP环境,其消耗是巨大的。

为了兼顾IIS下PHP的效率和安全,微软给出了FastCGI的解决方案。FastCGI可以让PHP的进程重复利用而不是每一个新的请求就重开一个进程。同时FastCGI也可以允许几个进程同时执行。这样既解决了CGI进程模式消耗太大的问题,又利用上了CGI进程模式不存在线程安全问题的优势。

因此,如果是使用ISAPI的方式来运行PHP就必须用Thread
Safe(线程安全)的版本;而用FastCGI模式运行PHP的话就没有必要用线程安全检查了,用None
Thread Safe(NTS,非线程安全)的版本能够更好的提高效率。

 

我该选择哪个版本?
如果你在apache1或者apache2下使用PHP,你应该选择VC6的版本
如果你在IIS下使用PHP应该选择VC9的版本
VC6的版本使用visual studio6编译
VC9使用Visual Studio
2008编译,并且改进了性能和稳定性。VC9版本的PHP需要你安装Microsoft 2008
C++ Runtime
不要在apache下使用VC9的版本

If you are using PHP with Apache 1 or Apache2 from apache.org you need
to use the VC6 versions of PHP
If you are using PHP with IIS you should use the VC9 versions of PHP
VC6 Versions are compiled with the legacy Visual Studio 6 compiler
VC9 Versions are compiled with the Visual Studio 2008 compiler and have
improvements in performance and stability. The VC9 versions require you
to have the Microsoft 2008 C++ Runtime (x86) or the Microsoft 2008 C++
Runtime (x64) installed
Do NOT use VC9 version with apache.org binaries我该选择哪个版本?

  1. 看了白菜(aiyooyoo.com)的修订,IIS安装php-cgi,3、4两步可以省略,ISAPI方式需要。
  2. 起名叫windows下的PHP版本的讲解更合适

Which version do I choose?

PHP5的版本主要分三支:PHP5.2之前的版本、PHP5.2.X和PHP5.3
那我们应该如何选择适用自己项目的版本呢?
PHP5.2之前的版本不值得考虑,因为某些功能缺陷或者BUG。
主流PHP程序对PHP5.2.X的兼容性最好,而每次版本号的升级带来的都是安全性和稳定性的改善,所以宜挑选最新的版本。目前PHP5.2系列最新的是PHP5.2.14
而如果产品是自己开发自己使用,PHP5.3在某些方面更具优势,在稳定性上更胜一筹,增加了很多PHP5.2所不具有的功能,比如内置php-fpm、更完善的垃圾回收算法、命名空间的引入、sqlite3的支持等等,是部署项目值得考虑的版本。

为了兼顾IIS下PHP的效率和安全,微软给出了FastCGI的解决方案。FastCGI可以让PHP的进程重复利用而不是每一个新的请求就重开一个进程。同时FastCGI也可以允许几个进程同时执行。这样既解决了CGI进程模式消耗太大的问题,又利用上了CGI进程模式不存在线程安全问题的优势。

TS和NTS
TS指Thread
Safety,即线程安全,一般在IIS以ISAPI方式加载的时候选择这个版本。
NTS即None-Thread Safe,一般以fast
cgi方式运行的时候选择这个版本,具有更好的性能。
下面给点资料,来源于
从2000年10月20日发布的第一个Windows版的PHP3.0.17开始的都是线程安全的版本,这是由于与Linux/Unix系统是采用多进程的工作方式不同的是Windows系统是采用多线程的工作方式。如果在IIS下以CGI方式运行PHP会非常慢,这是由于CGI模式是建立在多进程的基础之上的,而非多线程。一般我们会把PHP配置成以ISAPI的方式来运行,ISAPI是多线程的方式,这样就快多了。但存在一个问题,很多常用的PHP扩展是以Linux/Unix的多进程思想来开发的,这些扩展在ISAPI的方式运行时就会出错搞垮IIS。因此在IIS下CGI模式才是
PHP运行的最安全方式,但CGI模式对于每个HTTP请求都需要重新加载和卸载整个PHP环境,其消耗是巨大的。
为了兼顾IIS下PHP的效率和安全,微软给出了FastCGI的解决方案。FastCGI可以让PHP的进程重复利用而不是每一个新的请求就重开一个进程。同时FastCGI也可以允许几个进程同时执行。这样既解决了CGI进程模式消耗太大的问题,又利用上了CGI进程模式不存在线程安全问题的优势。
因此,如果是使用ISAPI的方式来运行PHP就必须用Thread
Safe(线程安全)的版本;而用FastCGI模式运行PHP的话就没有必要用线程安全检查了,用None
Thread Safe(NTS,非线程安全)的版本能够更好的提高效率。

如果你在apache1或者apache2下使用PHP,你应该选择VC6的版本
如果你在IIS下使用PHP应该选择VC9的版本
VC6的版本使用visual studio6编译
VC9使用Visual Studio
2008编译,并且改进了性能和稳定性。VC9版本的PHP需要你安装Microsoft 2008
C++ Runtime
不要在apache下使用VC9的版本TS和NTS
TS指Thread
Safety,即线程安全,一般在IIS以ISAPI方式加载的时候选择这个版本。

发表评论

电子邮件地址不会被公开。 必填项已用*标注