【永利官网ylg客户端】自家的Linux入门之旅

对于Ubuntu
10.04,使用自带的Ubuntu软件中心装好aMule和aMule-utils之后,在Firefox的about:config配置页中加入ed2k协议的打开方式为/usr/bin/ed2k,bool项设为true表示可以调用外部处理程序。

4.下载工具
    wget是系统自带的命令行单线程下载工具,也可以用命令 sudo apt-get
install gwget 安装图形版本。
    axel是一个命令行多线程下载工具,用命令 sudo apt-get install axel
安装,暂时未发现有图形版本。
   
lftp是系统自带的命令行FTP下载工具。图形界面的FTP下载工具推荐CrossFTP,但是它需要Java支持。
    aMule是Linux下的ed2k/kad客户端。推荐使用aMule-dlp,
这是带有动态吸血保护的aMule。
    a.到 处下在源代码。
    b.用命令 tar -jxvf aMule-2.2.6-DLP4102.tar.bz2 解压缩。
    c.用命令 sudo apt-get install g++ binutils-dev libcrypto++-dev
libgtk2.0-dev libgd2-xpm-dev libgeoip-dev libupnp3-dev zlib1g-dev
libwxbase2.8-dev libwxgtk2.8-dev 安装编译环境,满足依赖关系。
    d.进入解压缩出来的文件集,用命令 ./configure –prefix=/usr/local
–disable-debug –enable-optimize –with-denoise-level=3 –enable-upnp
–enable-geoip –enable-nls –disable-amule-gui –enable-amule-daemon
–enable-amulecmd –disable-webserver –disable-alcc -enable-alc
–enable-cas –enable-wxcas –enable-mmap 配置源代码。
    e.用命令 make 编译,编译过程比较长,要耐心等待。
    f.用命令 sudo make install 安装。
    g.为了让aMule有事件通知,在终端中 执行 sudo apt-get install
libnotify-bin 。安装完成后,打开aMule,点击 设置->事件->下载已完成
,勾上下面的两个选项,在边上两个输入框中输入: notify-send -i amule
aMule 下载完成:%NAME 。
    h.Firefox中启动aMule:
        * 打开Firefox,在地址栏中输入 about:config 并打开。
        * 新建一个布尔值,名字为 network.protocol-handler.external.ed2k
,值为 true 。
        * 新建一个字符串,名字为 network.protocol-handler.app.ed2k
,在我的系统中,值为 /usr/bin/ed2k 。也许在你的系统中是
/usr/bin/ed2k.amule 或者 ed2k.amule 了,视情况而定!
        * 用命令 sudo apt-get install amule-utils
安装”amule-utils”套件。
        *
接着找个ed2k的连结点击它,跑出询问关联的视窗,记住不要使用默认的,点选其他程序,照着路径
/usr/bin/ed2k 找出你系统中的ed2k程序来使用。
       
注意:设置完后记得重启Firefox生效。在Firefox中点了链接后只是将下载链接加到下载列表里,并不会自动打开aMule,需要手动打开才开始下载。
    Ubuntu 10.04 LTS自带了Transmission来支持BT下载。此为图形界面程序。

<RDF:li RDF:resource=”urn:scheme:webcal”/>

下载服务器列表可用这里的,KAD 更新地址可用这个及另一个。

这样一来还不行,在Firefox的首选项-应用程序里面仍然没有ed2k协议和对应于ed2k协议的处理程序的映射关系。这是因为还没有安装aMule的gnome支持,也就是aMule-gnome-support。装好之后就OK了。重启Firefox,就可以打开ed2k的链接了。

2.中文化方案
    Ubuntu 10.04
LTS的中文有点残废,安装好系统重新启动后,你会发现系统很多地方还是英文的,不过没关系,大约10来秒钟后,系统会弹出一个对话框,告诉你缺少中文,点击Run
this
action根据提示进行修复(需要网络)。过一会儿后,修复过程结束。不过因为字体的原因,有些偏僻的汉字是无法显示的,点击
系统->首选项->外观->字体
,将下面6处字体改成文泉驿的字体即可。
    Ubuntu 10.04 LTS默认的拼音输入法也是残废的,根本打不出中文来。点击
系统->首选项->IBus首选项->输入法 ,删除全部输入法,添加
汉语-Pinyin,汉语-五笔86 输入法即可。汉语-py(m17n)可保留,不过不好用。

<RDF:li RDF:resource=”urn:scheme:mailto”/>

永利官网ylg客户端 1

永利官网ylg客户端 2

本文记录了这3天来我学习Linux的一些心得,高手轻喷~

第一,在Firefox地址栏里输入about:config进行配置,添加network.protocol-handler.app.ed2k,类型为字符串,值为/usr/bin/ed2k,network.protocol-handler.expose.ed2k,类型为布尔,值为false,network.protocol-handler.external.ed2k,类型为布尔,值为true。www.linuxidc.com 完成后重启Firefox即可。

永利官网ylg客户端 3

1.安装Linux
    我安装的是Ubuntu 10.04
LTS,由于我准备长期驻扎在Linux上,所有我清空了整个硬盘来安装Ubuntu,过程简单,没什么好提的。如果想实现Windows与Linux双系统,要先安装Windows后在安装Linux,因为Windows很霸道,只认自家的兄弟,只要不是M$的,就当作没看见,直接覆盖MBR,原来Linux的引导程序就没了,要拿LiveCD修复。

关于Firefox与aMule的关联,其实就是Firefox与ed2k协议的关联,网上主要流传着两种说法。

sudo apt-get install amule

3.Firefox
    Firefox是Ubuntu 10.04 LTS自带的浏览器,点击 编辑->首选项->内容
,把默认字体也改成文泉驿的字体,点击旁边 高级
按钮,里面也改成文泉驿的字体。
   
Firefox有很多很好的插件,由于我接触Linux才3天,很多优秀的插件我都还没有用到,因此,在这里我只向大家推荐3款插件:
    a.FireGot 
FireGot是一款下载插件,能很好的代替Firefox的下载管理器。
    b.FireFTP  FireFTP是一款FTP插件。
    c.Reload Every  Reload
Every是一款自动刷新页面的插件,挂论坛时间必备。
   
搜狗推出了搜狗云输入法,有相应的Firefox插件,不过搜狗云输入法只能在浏览网页的时候使用,是不能当系统输入法的。而且,搜狗云输入法需要网络,网络不好的时候会打不出字来~~

虽然这两种方法都不能解决问题,但是从第二种方法里,我们能找到突破口。既然“应用程序”里没有ed2k,那就自己添加进去。我们知道“应用程序”里是不能直接添加的,只能通过其他途径。经过摸索得知,Firefox与此对应的配置文件为mimeTypes.rdf。Firefox的mimeTypes.rdf有好几个,其中/root/.mozilla/firefox,/home/users/.mozilla/firefox才是接下来要用到的(这里的users代表用户名,可根据具体情况作更改)。

配置:

0.废话一下
知道有Linux这个操作系统是在小学的时候,但因为种种原因,一直没有机…

从这里我们可以看出useSystemDefault即为“应用程序”里的“使用系统默认”,alwaysAsk为“总是询问”,下面两行<NC: 
/>是可选应用程序。由于我们只需要用到ed2k,可以把这两行<NC:
/>省略,然后改mailto为ed2k,useSystemDefault=”false”,alwaysAsk=”true”(还是要再提醒一下,不是直接在上面改,而是先复制这一整段并粘贴其后,再在后面这一段进行修改)。

如果需要将 aMule 与 Firefox 浏览器相关联,可以把
network.protocol-handler.app.ed2k 的字符串设置为 /usr/bin/ed2k。

0.废话一下
   
知道有Linux这个操作系统是在小学的时候,但因为种种原因,一直没有机会接触它。到了高中的时候,在VMware中安装过几次Linux,但是每次安装后没几天就忘记帐号密码进不去了~~现在终于有机会好好学习Linux了。话说那个。。。(此处省略一万字)

顺利安装aMule后,接下来要解决的问题是Firefox与aMule的关联问题。

aMule 是一个类似于 eMule 的多平台 P2P 客户端程序。以下将简略叙述 aMule
在 Ubuntu 中的安装及配置
[High ID] 与 [KAD] 的过程。

5.影音娱乐
   
据说Mplayer这个播放器是目前这个星球上支持多媒体文件格式最多的软件。不过要用命令行来配置它,很麻烦,可以安装SMPlayer,SMPlayer是MPlayer的一个图形化前端。
    a.用 sudo apt-get install smplayer 命令来安装SMPlayer。
    b.用 sudo apt-get install gecko-mediaplayer
命令来安装Firefox的插件,此插件捆绑gnome-mplayer。
    Audacious是Linux上安装最多的音频播放器。
    a.用 sudo apt-get install audacious 命令安装Audacious。
    b.用 sudo apt-get install audacious-plugins 命令安装解码器。
    c.点击 设置->播放列表 ,选择 使用自动编码检测器:简体中文
,备用字符编码:cp936 。

其他几个mimeTypes.rdf也用同样的方法修改、保存。最后,打开Firefox的“应用程序”,找到ed2k,并将关联程序指定为/usr/bin/ed2k。至此,aMule与Firefox的关联完成,aMule可像迅雷等下载工具一样使用了。

sudo apt-get install amule-utils

发表评论

电子邮件地址不会被公开。 必填项已用*标注