ylg娱乐官网安装rrdtool时候的报错configure: error: Please fix the library issues listed above and try again

在安装过程中,出现

如果还报错configure: error: Please fix the library issues listed above
and try again. 请看

免费下载地址在

# make

免费下载地址在

./configure –prefix=/usr/local/rrdtool

解决方法:

解决办法如下:

configure: error: Please fix the library issues listed above and try
again错误

作者 gaoming655

tar zxvf cgilib-0.5.tar.gz
cd cgilib-0.5
make
cp libcgi.a /usr/local/lib
cp cgi.h /usr/include

如出现以下错误,解决错误后重新编译

根据网上搜索,解决方法如下

    安装 cgilib-0.5.tar.gz

安装rrdtool时候的报错configure: error: Please fix the library issues
listed above and try again:

一、

第一:
安装 cgilib-0.5.tar.gz
从本页的最后下载cgilib-0.5.tar.gz
tar zxvf cgilib-0.5.tar.gz
cd cgilib-0.5
make
cp libcgi.a /usr/local/lib
cp cgi.h /usr/include
如果还不行,请看

yum –y install libart_lgpl-devel

具体下载目录在 /2012年资料/8月/2日/cgilib下载/

这里使用1.3.8版本的rrdtool源码包。

第三:
把这两个包装上pango-devel cairo-devel
yum –y install pango-devel* cairo-devel*
然后 在
cd cd rrdtool-X.X.X
./configure –prefix=/usr/local/rrdtool
这样肯定能行,一般在第二部就能解决了。
如果还是不行的话,试试yum install libxml2-devel
我就是yum install libxml2-devel解决的

从这里下载:

第一:

下载地址:

用户名与密码都是www.linuxidc.com

 

安装 cgilib-0.5.tar.gz
从这里下载:

安装libxml

具体下载目录在 /2013年资料/4月/18日/rrdtool出现configure

yum –y install pango-devel* cairo-devel*

如果还不行,请看

checking for XML::Parser… configure: error: XML::Parser perl module is
required for intltool

ylg娱乐官网 1

weget

第三:

checking for intltool >= 0.35.0… 0.31.2 found

cgilib-0.5.tar.gz下载

: error: Please fix
the library issues listed above and try again的问题 configure: error:
Please fix the library issues listed above and try…

然后

2)安装net-snmp-utils软件包

第二:
安装libart_lgpl-devel这个包
yum –y install libart_lgpl-devel
如果还报错configure: error: Please fix the library issues listed above
and try again. 请看

  把这两个包装上pango-devel cairo-devel

用户名与密码都是www.linuxidc.com

# ./configure –prefix=/usr/local/

                 第一:

第二:

# ln -s /usr/local/include/libxml2/ /usr/include/libxml2

make  www.2cto.com  

把这两个包装上pango-devel cairo-devel
yum –y install pango-devel* cairo-devel*
然后在
cd cd rrdtool-X.X.X
./configure –prefix=/usr/local/rrdtool
这样肯定能行,一般在第二部就能解决了。

解决办法如下:

cd cd rrdtool-X.X.X

ylg娱乐官网 2

# cd /usr/src/rrdtool-1.3.8/

发表评论

电子邮件地址不会被公开。 必填项已用*标注